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ECHO Automation Products, Your Successful Choice 

Honorable users: 

Welcome to use our automation products and service manuals. 

With continual improvement of product quality, technical application and service 

support, Digitron-itralia has successfully launched Rock E series 

PLC and SuperE series RTU /PLC products, which have been widely applied in 

automation industry fields. Our products have excellent performance in various 

application environments and have been appreciated by experts and users. 

If you use our products for the first time, please carefully read Service Manual when 

purchasing and using products. In this way, you can further understand 

performances of our products, reasonably configure hardware and software resource, 

and truly make our products become the most successful choice. 

Automation Products Manuals include: 

 "SuperE40 Series RTU Manual " 

 "Super32 RTU Manual " 

 “OpenPCS User Manual” 

 "ESet Manual " 

 “Flow Computer User Manual” 

 "DNP3 Configuration Manual" 

 

We will continually update Service Manual and supply site application programs and 

documents. For any difficulty and problem, please contact our technical service 

department  and we will timely response and help you 

to solve the problem. You can also access to our website, inquire relevant data and 

obtain application help from "technology resource ". 

 

 



  

Copyright Statement 

 

 

 

 

 

Super32 RTU Manual is written by Digitron Italia 

Applicable to 32 bit series controllers developed by our company. Super32 RTU 

Manual is protected by intellectual property, and shall not be counterfeited, stolen or 

illegally copied. 

In addition to trademarks, products and software names, the contents stated in the 

manual shall not be duplicated, distributed, converted, transferred or saved in any 

form of system. The contents involving intellectual property stated in the manual shall 

not be transferred in any form without our written permission. 

Products and company names available in this manual belong to registered trademark 

and copyright, and owned by Digitron Italia. These 

products, company names, registered trademarks and copyrights shall not be 

counterfeited except applied as description and explanation. 

 

 

 

 

 

Legal Responsibility 

The manual is only for reference, without any warranty, and mainly aims to supply 

information related to product application. We will be not liable to any damage of 

benefits and products due to the contents of the manual used for other purposes. 

Meanwhile, to meet the requirement of product update



 reserves the right to modify manual without notice. 

 

 

 

 

 

About Manual 

 Content 

The manual is applicable to Super32 Series RTU. Mainly include product introduction, 

installation application, technical service, etc.: 

 

 Product Introduction 

Introduce product configuration, parameter settings, performance target, etc. 

 

 Installation and Application 

Introduce product installation, program development, application method, etc. 

 

 Technical Service 

Introduce technical support, after service, etc. 

 

 

 

 

 



  

The Potential Readers 

 

 

 

 

 

Reading Super32 RTU Manual needs certain engineering knowledge. The manual is 

written for product application engineers, etc. 

 

 

 

 

 

How to Use the Manual 

If using Super32 RTU for the first time, please read through the manual. If you are an 

experienced user, can search corresponding information through chapters. Manual 

content arranged in following chapters: 

Chapter 1. Summary 

Chapter 2. Dimensions and Mounting  

Chapter 3. Field Wiring  

Chapter 4. Operation 

Chapter 5. Controller Specification 

Appendix A. Program Development of Controller 



Appendix B. Field Wiring Of All Super32 Types 

 

 

 

 

 

Other Help Information 
 Electronic Manual 

While supplying products, we will also supply CD including Super32 Series RTU and 

help, etc., please install it on computer for use. 

 

 Development Help 

After completing control system, users can adopt EOpen software by ECHO to 

develop Super32 controller, application methods see our corresponding user 

manuals. 

 

 Product Debugging 

A series of product debugging programs are included into the CD to help 

understanding product features as quickly as possible. These debugging programs 

can be obtained from our website. 

 

 Technical Support 

For technical consultation, product application training and common difficult problem, 

please contact us or access our website. 



  

 Sale Service 

For product purchase, order and repair, please contact us and our product agents. 

After receiving products, to ensure your basic benefit, please timely fill in and return 

product warranty card to us. 
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Chapter 1. 0Summary 

 

 

 

 

 

The Super32 RTU is a series of new style common programmable controllers, 

responsible for signal acquisition and equipment control in situ oriented. With 

advanced MCU, the products can not only fulfill logic, timing control but also realize 

data processing, high speed counting, analog quantity control, PID, RTD, TC, 

communication, networking and so on. 

The Super32 RTU adopt the standard open design. By comparing with other common 

programmable controllers, the products have the following characteristics: larger 

memory capacity, stronger calculation function, simple and convenient programming; 

powerful communication and network integration capacities which are easy to 

integrate the network control system with the upper computer and realize distribution 

control; multiple configurations and function selections which can be ordered 

according to user needs (system integration, developing and application); 

superexcellent temperature characteristic and stronger adaptive capacity to 

environment enable the products to work normally in ill-being. In a word, the series 

products have the merits of reliable performance, comprehensive functions, flexible 

applications and high cost-performance ratio. The series products have been widely 

used in the fields such as petrochemical industry, electric power, metallurgical 

industry, heat supply, boiler, atmospheric environment, water regime, water supply, 

sewage disposal, street lamp monitoring, intelligent building and municipal works. 
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1.1 Product Characteristics 

 Advanced 32-bit ARM chip (ARM technology), embedded real-time multitasking 

operating system (RTOS). 

 Conform to IEC61131-3; support LD, FBD, IL, ST and SFC programming 

languages; provide the standard C language program interface. 

 Support I/O signal data collection, logical control and process control; there are 

several controllers available to meet users' different kinds of demands, the I/O 

quantities also can be ordered according to user requirements. 

 Support communication protocols such as Modbus RTU/ASCII/TCP, DNP3, have 

communication interfaces such as RS232, RS485, Ethernet and Hart. 

 The power supply, the signal output and input terminals have been adopted 

insulation blocking and isolated from the main control circuit. 

 Data power-off protection function, which can store parameters and history data 

for a long term. 

 The industrial standard design and the DIN guide rail installation structure are 

convenient for field installation and configuring interior hardware. 

 Premium components and parts that have been checked and screened strictly. 

 Working temperature: - 40 ~70ºC, humidity: 5 ~ 95%RH, applicable for connection 

of controllers in different kinds of ill-being. 
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1.2 Application Requirements 

The Selection of the Super32 series RTU should according to the practical 

requirements which can be divided into several aspects as follows: 

 Program requirements 

 Communication requirements 

 I/O requirements 

 Power supply requirement 

 

1.2.1 Programming Requirements 

A programmable RTU controller, such as Super32-L201, Super32-L202, 
Super32-M201 is required when: 

 The controller can execute local or remote program control. 

 If there is more than one slave station, the controller is a master station. 

 Data must be saved, processed or stored in the controller in the form of log. 

A non-programmable controller may be used when: 

 The application System is a terminal-terminal target system. 

 The controller is used for the Remote I/O or subsidiary I/O of a master controller. 

 Without demand such as local control or judgement. 

 

1.2.2 9Communication Requirements 

The communication requirement includes the required kinds and quantities of COM 

ports of controller. The controller may have any one or several kinds of representative 

communication modes as follows: 

 Remote slave station 
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Chapter 2. Dimensions and Mounting 

 

 

 

 

 

2.1 Outline Dimensions 

 

Fig. 2-1  

 

2.2 Mounting Controller 

Super32 controllers mount on 7.5mm by 35mm DIN type rails, as following picture 

show: 

 

Fig. 2-2 DIN Type Guide Rail  
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2.2.1 Mounting Guidelines 

Follow these guidelines for mounting modules:  

 DIN rails mount horizontally or vertically, where generally mount horizontally. 

Modules are easier to install on horizontal rails. Cooling is optimal when mounted 

horizontally.  

 All the components of Super32 controllers pass the electric certification. 
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2. Slide the clamp outward, the bottom of the clamp will be outside of the bottom of 

Super32, as following picture show: 

 

Fig. 2-5 

 

3. Drag the controller outward, until the hooks is over the inward lip of the DIN rail, as 

following pictures show:  

 

Fig. 2-6 

 

4. Slide the clamp inward until it meets the outward lip of the rail. The lower edge of 

the clamp will be flush with the bottom of the controller, as following pictures show:  

   

Fig. 2-7 
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Chapter 3. Field Wiring 

 

 

 

 

 

3.1 Outline 

The following figure has displayed the outline of Super32-L202 RTU. 

 

 

Fig. 3-1 The Outline of Super32-L202 
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3.2 Field Wiring Connectors 

The connecting terminal of Super32 RTU can be divided into three parts: 

 Power supply input terminal. 

 I/O signal wire connecting terminal, such as AI, DI , DO,AO, PI, PO, Wake up, 

HART etc. 

 Local/Remote communication terminal, such as COM1(RS232/RS485), COM2 

(RS232) and the Ethernet interface. 

Super32-L202 for example, the distribution of terminal groups has been shown as 

follows: 

1) Down Board 

P6

P4P2 P5P1 P3

WAKEUP

-+

Ethernet

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4DI3DI2DI1DI0

LEDs 

P8

Data

COM1 COM2COM1

DI ,Wake up  
Termination Connector

Power,AI Termination 
Connector

DO Termination 
Connector

 Super32-L202 Down Board   

Fig. 3-2  

 

P1 terminal (including power supply, AI output terminal) has been shown in the figure. 
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1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig. 3-3 

 

P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig. 3-4 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

 

Fig. 3-5 

 

P4 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig. 3-6 
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Fig. 3-9 

P7 terminal (including HART, PI, AO signal terminal) has been shown in the figure. 

32 33 34 35 36 37 38 39 40

PI1PI0
PI

COM

P7
30 31

H0-H0+ PI2

41 42 43 44 45

AOV+ AOV- AO0 AO1H1-H1+ H2-H2+ AOV- AOV-

 

Fig. 3-10 
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3.3  Connection Mode 

3.3.1 Power Supply Input Wiring 

The power supply mode of Super32 RTU is DC24V. 

1 2 3

V+ V-
 

Fig. 3-11 

 

 “⊥” terminal, is Super32 RTU grounding terminal. 

In most of application, the best system grounding method is connecting the ground of 

the system power supply to the ground of chassis or panel of the cabinet. As far as 

Super32 concerned, after connected  terminal with the chassis or earth ground, 

the grounding work of controller has been completed.  

Connect "V+" terminal to the "+" end of24V DC. 

Connect "V-" terminal to the "-" end of 24V DC. 

      

3.3.2 Analog Input（AI）Wiring 

The AI signal input end has equipped with overvoltage and overcurrent protection to 

avoid spoilage because of false field connection. The field connection can be divided 

into two-wire system and three-wire system.  

The connection mode has been shown as follows: 
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Filter PI0

37 38 4039

PI
PI0 PI1 PI2 PI-

P7

8~24 V

PULSE
OUTPUT

+

+

_

_

ON

Filter PI1

Filter PI2

 

Fig. 3-16  PI Field Wiring 

 

Every counter input has a jumper wire selected filter which limits the maximum input 

frequency. Use a filter with 50 or 60 HZ AC digital inputs to eliminate contact bounce. 

The factory default state of this jumper wire selected filter is disabled. 

 

3.3.7 Counter Output（PO）Wiring 

PO1 PO2PO0 24V
GND

L
O
A
D

L
O
A
D

L
O
A
D

L205

 

Fig. 3-17 

 

 

 

20                                                                    Super32 RTU Manual 







                                                            Chapter 3 Field Wiring 

Super32 RTU Manual                                                   
23 

 



Chapter 3 Field Wiring                                                             

3.3.8.2 RS232 DTE to RS232 DTE without Handshaking 

The following figure has shown a standard connection mode between RS232 port and 

DTE without handshaking signal 

RS232(DTE)

9

2

1

3

4

5

6

7

8

9

2

1

3

4

5

6

7

8

DCD

RXD

TXD

DTR

GND

RTS

CTS

DCD

RXD

TXD

DTR

GND

CTS

DTE

 

Fig. 3-19 RS232 DTE to RS232 DTE without Handshaking 

 

3.3.8.3 RS232 DTE to RS232 DTE with Handshaking 

Some DTE (Data Terminal Equipments) need handshaking signal wires. The common 

wires are CTS and RTS, DTR and DCD are used rarely. The controller has no need of 

these wires. For details, please refer to the relevant manuals of DTE. 

The following figure has shown a standard connection mode between RS232 port and 

DTE with handshaking signal. 
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RS232(DTE)

9

2

1

3

4

5

6

7

8

9

2

1

3

4

5

6

7

8

DCD

RXD

TXD

DTR

GND

RTS

CTS

DCD

RXD

TXD

DTR

GND

RTS

CTS

DTE

 

Fig. 3-20  RS232 DTE to RS232 DTE with Handshaking 

 

3.3.8.4 RS232 DTE to RS232 DCE with Handshaking 

DCE (data communication equipment) needs different signal wires, but in the most 

general case, DCE must be connected with handshaking signal wire. Note: a majority 

of DCE belongs to half-duplex communication; when using these equipments, 

half-duplex should be selected. 

The following figure has shown a representative connection mode between RS232 

port and DCE with handshaking signal. 

RS232(DTE)

9

2

1

3

4

5

6

7

8

9

2

1

3

4

5

6

7

8

DCD

RXD

TXD

DTR

GND

RTS

CTS

+5V

DCD

RXD

TXD

DTR

GND

RTS

CTS

+5V

DCE
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end grounding 
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Fig. 3-23  RS485 Field Wiring －Two-wire Mode   

 

3.3.9.3 Termination Resistors 

Termination resistors of 120Ω are required on both physical end on one network 

segment ,it also means that the two communication ports which on the physical end 

position of one network segment must be connected with termination resistors, other 

communication ports of this net segment should not be connected with termination 

resistors. See Fig. 3-23  RS485 Field Wiring －Two-wire Mode. 

These termination resistors are installed to make sure the receive data can still be 

right for the following conditions on the RX line:  

 Open inputs 

 Terminated inputs 

 Sudden inputs (shorted circuit) 
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3.3.10 HART Communications Wiring 

Super32 controller contains 3 HART protocol communication ports ,one of these is 

multi-branched port which can connect 13 HART protocol meters. The other two are 

point to point port which can not only connect HART protocol meters but also collect 

4~20mA signals to meet different user’s requirements.  

Wiring Mode： 

1. multi-branched port wiring mode 

Controller’s HART0 communication port is multi-branched port.  

-

Two Wire
Slave #1

+

......

H0+ H0-

-

Two Wire
Slave #2

+

-

Two Wire
Slave #13

+

30 31

DC Power
Supply

+

-  

Fig. 3-24 HART0 Field Wiring of Passive Meters 

 

+

Active
Slave #1

-

......

H0+ H0-

+

Active
Slave #2

-

+

Active
Slave #13

-

30 31

DC Power
Supply

+

-  
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Fig. 3-25 HART0 Field Wiring of Active Meters  

2. Point to point wiring mode of HART1, HART2 

-

Two Wire
Slave #1

+

H1+ H1-

32 33

DC Power
Supply

+

-

-

Two Wire
Slave #2

+

H2+ H2-

34 35

DC Power
Supply

+

-  

Fig. 3-26 HART1, HART2 Field Wiring of Passive Meters  

 

+

Active
Slave #1

-

H1+ H1-

34 35

DC Power
Supply

+

-

+

Active
Slave #2

-

H2+ H2-

34 35

DC Power
Supply

+

-  

Fig. 3-27 HART1, HART2 Field Wiring of Active Meters 

 

3.3.11 Ethernet Communication Port 

The Super32 controllers have been equipped with built-in Ethernet communication 

module, before leaving factory. 
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3.3.13 CAN Bus Wirings 
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24V
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Fig. 3-32 
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Chapter 4. Operation 

 

 

 

 

 

4.1 Operating Modes 

Super32 controllers may start up in RUN and SERVICE mode. Starting the controller 

in RUN mode automatically executes OpenPCS programs in the controller memory. 

Starting the controller in SERVICE mode allow controller initialization. 

 

4.1.1 Run Mode 

The RUN mode is the normal or default operating mode of the Super32 Controller. No 

action is required to select RUN mode. When power is applied to the controller board:  

  The user defined serial communication parameters, for all COM ports are used.  

  If an OpenPCS program is loaded in RAM, it is executed. 

 

4.1.2 9Service Mode 

SERVICE mode is used during application programming and maintenance work. 

Using the following procedure to select SERVICE mode:  

  Remove power from the controller.  

  Connect PC to COM2 port of the controller throw a serial line.  

 Executing OpenPCS program, choose [Extras]→ [Tools]→ [PC Communication 
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Settings] in the menu., and the dialog [ESI] will pop up, then select “Connect 

controller”.  

  Power up the controller, the it will run in Service Mode. 

When the Super32 controller starts in SERVICE mode, following functions can be 

achieved through configuration, see Eset Manual for more details. 

  Clear OpenPCS program.  

  Initialize controller communication parameter.  

  Initialize Register.  

  Test Communication. 

 

4.2 Sleep Mode 

Super32 Controllers are capable of extremely low power operation when in sleep 

mode. During sleep mode the following happen:  

 All programs stop executing.  

 The power supply of 3.3V which supply power for circuit shut down.  

 The real-time clock and timer continue to function.  

 12V DC power is not affected.  

 

Super32 controllers can switch to sleep mode under control of the application 

program. One of the following conditions occur to will make the controller switch to 

sleep mode.  

  A real time clock alarm, defined by application program, occurs.  

  A signal is applied to the WakeUp input. 
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4.4 Power Control 

4.4.1 LED Power Control 

Lightening the LEDs on the Super32 controller board will consume a lot of power. 

Controller can shut these LEDs to conserve power. This feature is particularly useful 

when the Super32 is using solar powered system or unattended work stations. 

The ESet configuration sets the default state of the LED power. Application 

programming can change the enable/disable status. See ESet Manual for detail. 

The LED power provides power for LEDs if enabled. 

PWR、RUN are not controlled by the LED power enable/disable status. 

 

4.4.2 COM1 Power Control 

The insulating power of COM1 port on the Super32 controller board will consume a lot 

of power. If the controller does not connect with a serial equipment, controller can shut 

the COM1port to conserve power. This feature is particularly useful when the Super32 

is using solar power. 

The enable/disable status of COM1 power is set by the ESet configuration tool. The 

application programming may change the enable/disable status. See ESet Manual   

for detail. 

TheCOM1 power provides power for COM1 if enabled. 

COM2 is not controlled by the COM1 power enable/disable status. 

 

4.4.3 Ethernet Power Control 

Ethernet port on the Super32 controller board will consume more power. If the 

controller does not connect with an equipment through Ethernet port, controller can 

shut the Ethernet port to conserve power. This feature is particularly useful when the 

Super32 is using solar powered. 
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The enable/disable status of Ethernet port power is set by the ESet configuration tool.. 

The application programming may change the enable/disable status. See ESet 

Manual for detail. 

The Ethernet port power provides power for Ethernet port if enabled. 

 

4.5 Counter Input Filters 

Each of the three counter inputs on the Super32 controller can be filtered. Filtering 

limits the maximum digital input or counter frequency to approximately 30 Hz. Pulse 

inputs uses filter to resolve for the problems of contact bounce in low speed counting 

applications. 

The FILTER 1, FILTER2, FILTER3 switches control the input filter functions:  

 Remove the module cover and set the configuration switches. See Fig. 3-9 

Super32 Controller Layout for switch location.  

 To disable a filter, dial the switch to the right side. (open)  

 To enable a filter, dial the switch to the left side. (closed)  

 

Fig. 4-2 

 

4.6 Real Time Clock 

The Real Time Clock of Super32 controller provides independently the time and date 

for the operating system。The time and date remain correct during power off. The 

calendar automatically manages leap years.  
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4.12 Communication Parameters 

The configuration for the parameters of controller should according to the 

requirements in situ. The primary configurations are parameters of serial 

communications, Ethernet IP and some other parameters which are relevant to 

control. For details, please see chapter Controller Communication Settings of ESet 

Manual.  

 

4.13 Lithium Battery 

A small lithium battery powers real-time clock when input power is removed. The 

voltage of a functioning battery should be greater than 2.0V. Application programming 

can monitor this voltage. If an application program will use the sleep function of 

controller, please notice about whether it is the voltage of the battery lower than 

2.0V.Otherwise, the controller may not be awakened. Refer to the ESet Manual for 

details.  

The battery need not be replaced under normal conditions. The using life of the 

battery is 10 years. The battery is rated to maintain the real-time clock and RAM data 

for two years with the power off. Accidental shorting or extreme temperatures may 

damage the battery.  

The battery is fixed on the circuit board. If necessary, a battery with same 

performance can be replaced battery seat needn’t to be changed. 













                                     Appendix A Program Development of Controller 

Super32 RTU Manual                                                                    51 

Appendix A Program Development of Controller 

 

 

 

 

 

A.1 Method of Development 

The Super32 RTU are programmable controllers which support secondary 

development to order user's required controllers. The required software for the 

development of control program is EOpen, which conforms to IEC61131-3. 

EOpen supports IL, LD, ST, SFC and FBD/CFC programming languages, which 

conform to IEC61131-3. According to the characteristics and requirements of project, 

users and programmers can select any one or several languages to program and 

engineers can complete the construction of automation engineering quickly and 

effectively. 

EOpen supports monitoring and debugging on-line, simulating off-line. It has strong 

functions of engineering applications such as controller parameters setup, I/O port 

read-write, monitoring database. 

For details, please see OpenPCS manual and ESet manual.  
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A.2 Flow of Development 

A.2.1 Read up the Communication Settings of Controller 

When given a Super32 RTU, we don’t know its communication settings such as the 

baud rate of serial port and the IP of Ethernet. Please see the chapter Test 
Communication of ESet manual to build up the connection.  

 

A.2.2 RS232 Connection Setup 

The procedure to build up RS232 connection in OpenPCS is as follows: 

Choose[PLC]→[Connections..] in the menu. A dialog will pop up:  

 

 

Fig.A- 1 

 

Click [new], the dialog [Edit Connection] will pop up: 
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Fig.A- 2 

 

Input a connection name in the [name] block (my_RS232 for example), See Fig.A-3. 

 

Fig.A- 3 

 

Click [Select], and the dialog [Select Driver] will pop up. See Fig.A-4. Select RS232 
driver, and click [OK]. 
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Fig.A- 4 

 

Click [Settings], and the dialog [RS232 Settings] will pop up. See Fig.A- 6. 

 

Fig. A- 5 
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Fig.A- 8 

 

Thus, the RS232 connection has been built up in OpenPCS. 

 

A.2.3 TCP Connection Setup 

The procedure to build up TCP connection in OpenPCS is as follows: 

Choose [PLC]→[Connections..] in the menu. A dialog will pop up: 

 

Fig.A- 9 

 

Click [new], the dialog [Edit Connection] will pop up, Input a connection name in the 

[name] block (my_TCP for example), see below. 
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Fig.A- 10 

 

Click [Select], and the dialog [Select Driver] will pop up. See Fig.A-11. Select TCP432 
driver, and click [OK]. 

Note to select the TCP432 driver when using Ethernet communication port, not TCP. 

 

Fig.A- 11 

 

 

Super32 RTU Manual                                                                    57 





                                     Appendix A Program Development of Controller 

 

Fig.A- 14 

 

 

Fig.A- 15 

 

Thus, the TCP connection has been built up in OpenPCS. 

 

A.2.4 OpenPCS Programming 

We use ST language for example to edit a program. 

1、create a new project named Super32_DO. 

Start OpenPCS , choose [File]→[New] in the menu, click [project], and select [Empty 
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Project]. See below：. 

 

Fig.A- 16 

 

 

Fig.A- 17 

 

Input a project name in the [name] block (Super32_DO for example), See below. 
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Fig.A- 18 

 

Now the browser contains the new project. You can find the project name in the files 

pane. See below. 

 

Fig.A- 19 
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2、Create a new program file named DO_ON.ST 

Choose [File]→[New] in the menu, select ST Program. Select [POU], and input a file   

name in the [name] block. See below.  

 

Fig.A- 20 

 

There may pop up a dialog inquiring whether adding this file to the active resource or 

not. Click [yes]. See below. 

 

 

Fig.A- 21 

 

You can find the program file name DO_ON.ST in the files pane of the browser. See 

below. 
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Fig.A- 22 

 

3、Create a new Direct Global declaration file named DO_DirectAddress.POE 

Choose [File]→[New] in the menu, click [Declarations], select [Direct Global], and 

input a name in the [name] block (DO_DirectAddress), then click [OK]. See below. 

 

Fig.A- 23 
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There may pop up a dialog inquiring whether adding this file to the active resource or 

not. Click [yes]. See below. 

 

Fig.A- 24 

 

You can find the program file name DO_DirectAddress.POE in the files pane of the 

browser. See below. 

 

Fig.A- 25 

 

4、Edit DO_DirectAddress.POE 

Click the file name DO_DirectAddress.POE in the file pane of the browser. And edit 

the direct global file in the right window. 
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Fig.A- 26 

 

The source code, please see Appendix A.3. 

 

5、Edit DO_ON.ST 

Click the file name DO_ON.ST in the file pane of the browser. And edit the ST 

program file in the right window. The variable declaration is in the upper window, and 

the executed code is in the lower window. 
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Fig.A- 27 

 

The source code, please see Appendix A.3 

. 

6、Edit resources properties 

The default resource will need to be configured properly for controller.  

Open the resources-pane in the left window.  

66                                                                    Super32 RTU Manual 



                                     Appendix A Program Development of Controller 

 

Fig.A- 28 

 

Find the ‘Resource’ entry in the Resource-Pane, and right-click it to show the context 

menu, and select ‘Properties’, see below: 

 

Fig.A- 29 
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[Edit Resource Specifications] dialog will pop up. Select “ECHO” in the [hardware 

module]. For the “network connection” item, you should select “my_RS232” when the 

hardware is RS232 serial connection (see Fig.A- 30 ) or select “my_TCP” when the 

hardware is TCP432 connection (See Fig.A- 31). Under ‘Optimization’, select ‘Size 

only’. Then click [OK].  

 

Fig.A- 30 

 

 

Fig.A- 31 

 

Note to avoid more than one software occupy the same serial port of controller when 

you use RS232 serial connection. 

 

7、Edit task properties 

In this example, we want to let the DO_ON task execute one time every second. so 

68                                                                    Super32 RTU Manual 



                                     Appendix A Program Development of Controller 

the DO_ON task will need to be configured to second interruption. 

Find the ‘DO_ON’ entry in the Resource-Pane, and right-click it to show the context 

menu, and select ‘Properties’, see below: 

 

Fig.A- 32 

 

The [Edit Task Specifications] dialog will pop up. Select “interrupt” In the “Task Type”, 

and Select “RTC_SEC” In the “Interrupt”. Click [OK]. See below. 

 

Fig.A- 33 
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8、Compile 

Choose [PLC]→[Build Active Resource] in the menu, or click [Build Active Resource] 

button in the toolbars. See below. 

 

Fig.A- 34 

 

You can see the compiling be running in the diagnostic output window. The last 

results will be displayed on the diagnostic output window. 
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Fig.A- 35 

 

9、Online 

After compiling finished, choose [PLC] → [Online] in the menu, or click 

[Online/offline] button in the toolbars to connect the controller. 
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Fig.A- 36 

 

10、Download  

 

Fig.A- 37 

 

11、Debug  

Double click variables which under DO_ON entry in turn to add them to the variable 

watch list. 
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Fig.A- 38 

 

12、Run  

Choose [PLC]→[Coldstart] in the menu, or click [Coldstart] button in the toolbars to 

reset all variables initial value.  
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Fig.A- 39 

 

A.2.5 Configuration 

The controller will not do any operation, because you have not done any configuration. 

We have set the DO_ON.ST task type as RTC_SEC interrupt (see Fig.A- 33), and 

now we should use ESet configuration software to enable the RTC_SEC event 

interrupt. 

1. Build up connection with ESet: 

Note that, if you use serial connection between ESet tools and the controller, you  

should firstly be offline in OpenPCS, because the controller can’t communicate with 

the two software at the same time. So click the [online/offline] button again, to turn to 

offline state. 

74                                                                    Super32 RTU Manual 



                                     Appendix A Program Development of Controller 

 

Fig.A- 40 

 

Choose [Extras]→[Tools]→[PC Communication Settings] in the menu. Set the PC baud 

rate the same as the connected serial port of controller, COM2, 57600 for example. As 

follows: 

 

Fig.A- 41  
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If you use TCP connection between ESet tools and the controller, you need to select 

“TCP/IP Server” in the “Connection Type”. 

 

Fig.A- 42 

nual for the corresponding relationship 

]→[Event Settings] in the menu. The [Event Settings] dialog 

will pop up. See below. 

 

2. Enable the task interrupt: 

We use Event Settings to enable the Second Event. You can see the start sentences 

in chapter Event Settings of ESet Ma

between the task interrupt and the Event. 

Choose [Extras]→[Tools

 

Fig.A- 43 
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Check the Second Event check box to enable the second event and [Download] to 

write the event settings to the controller. See below. 

 

Fig.A- 44 

 

 

Fig.A- 45 

A.2.6 Controller Operation 

roller start to execute the OpenPCS program to operate 

e On/Off switch secondly.  

 

Now, you will find that the cont

th
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A.3 Source Code Of The Example 

 

1. source code of  DO_DirectAddress.POE 

VAR_GLOBAL 

(*Super32-II variables defined*) 

(*4DO*) 

Super32_DO_0 : BOOL AT %QX0.0; (*WRITE COIL REGISTER 00001*) 

Super32_DO_1 : BOOL AT %QX0.1; (*WRITE COIL REGISTER 00002*) 

Super32_DO_2 : BOOL AT %QX0.2; (*WRITE COIL REGISTER 00003*) 

Super32_DO_3 : BOOL AT %QX0.3; (*WRITE COIL REGISTER 00004*) 

(*8DI*) 

Super32_DI_0 : BOOL AT %IX0.0; (*READ STATE REGISTER 10001*) 

Super32_DI_1 : BOOL AT %IX0.1; (*READ STATE REGISTER 10002*) 

Super32_DI_2 : BOOL AT %IX0.2; (*READ STATE REGISTER 10003*) 

Super32_DI_3 : BOOL AT %IX0.3; (*READ STATE REGISTER 10004*) 

Super32_DI_4 : BOOL AT %IX0.4; (*READ STATE REGISTER 10005*) 

Super32_DI_5 : BOOL AT %IX0.5; (*READ STATE REGISTER 10006*) 

Super32_DI_6 : BOOL AT %IX0.6; (*READ STATE REGISTER 10007*) 

Super32_DI_7 : BOOL AT %IX0.7; (*READ STATE REGISTER 10008*) 

 

(*8AI*) 

Super32_AI_0 : UINT AT %IW512.0; (*READ INPUT REGISTER 30001*) 

Super32_AI_1 : UINT AT %IW514.0; (*READ INPUT REGISTER 30002*) 

Super32_AI_2 : UINT AT %IW516.0; (*READ INPUT REGISTER 30003*) 
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Super32_AI_3 : UINT AT %IW518.0; (*READ INPUT REGISTER 30004*) 

Super32_AI_4 : UINT AT %IW520.0; (*READ INPUT REGISTER 30005*) 

Super32_AI_5 : UINT AT %IW522.0; (*READ INPUT REGISTER 30006*) 

Super32_AI_6 : UINT AT %IW524.0; (*READ INPUT REGISTER 30007*) 

: UINT AT %IW526.0; (*READ INPUT REGISTER 30008*) 

_2 : UINT AT %Q516.0; (*WRITE HOLD REGISTER 40003*) 

518.0; (*WRITE HOLD REGISTER 40004*) 

O_ON.ST 

tion*) 

uper32_DO_2 : BOOL ;  

_3 : BOOL ;  

GLOBAL 

Super32_AI_7 

 

(*4AO*) 

Super32_AO_0 : UINT AT %Q512.0; (*WRITE HOLD REGISTER 40001*) 

Super32_AO_1 : UINT AT %Q514.0; (*WRITE HOLD REGISTER 40002*) 

Super32_AO

Super32_AO_3 : UINT AT %Q

END_VAR 

2. source code of D

(*variables declara

VAR_EXTERNAL 

(*Super32_DO*) 

Super32_DO_0 : BOOL ;  

Super32_DO_1 : BOOL ;  

S

Super32_DO

 

END_VAR 

VAR_

END_VAR 

VAR 
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END_VAR 

(*executing code*) 

Super32_DO_0 := NOT Super32_DO_0;  

Super32_DO_1 := NOT Super32_DO_1;  

uper32_DO_2 := NOT Super32_DO_2;  

Super32_DO_3 := NOT Super32_DO_3; 

 

S
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Appendix B Field Wiring of all Super32 Types 

 

 

 

 

 

B.1 Super32-M201 

B.1.1 Field Wiring Connectors 

The distribution of Super32-M201 terminal groups shown as follows:  

P6

P4P2 P5P1 P3

WAKEUP

-+

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4D3DI2DI1DI0

    Super32-M201  

P8

Data

COM1 COM2COM1

DI 、Wake up  

Power、AI DO 

LEDs

 

Ethernet

(Reserved)

 

Fig.B- 1 
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P1 terminal (including power supply, AI output terminal) has been shown in the figure.  

1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig.B- 2 

 

P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig.B- 3 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

       

Fig.B- 4 

 

P3 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig.B- 5 
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Note: P3 and P4 are both COM1 serial ports, they can not be used in RS485 and 

RS232 at the same time. Only one of them can be selected.  

P5 terminal (including RS232 communication terminal) has been shown in the figure, 

it belongs to COM2. 

 

Fig.B- 6 

 

P6 terminal (including DI , Wake Up signal terminal ) has been shown in the figure. 

21 22 23 24 25 26 27 28 29

DI3 DI4 DI5 DI7DI6DICOM DI2

P6

WAKE UP
+ -

19 20

DI1DI0
 

Fig.B- 7 

 

B.1.2 LEDs Indicators 

PWR STAT

RUN ERR

DO0 DO2

DO1 DO3

DI0 DI2

DI1 DI3

DI4

DI5

DI6

DI7

PI0

PI1

PI2 TX0

RX0

TX1 TX2

RX1 RX2LINK

TX

RX

 

Fig.B- 8 
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B.2 Super32-L201 

B.2.1 Field Wiring Connectors 

The distribution of Super32-L201 terminal groups shown as follows: 

P6

P4P2 P5P1 P3

WAKEUP

-+

Ethernet

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4DI3DI2DI1DI0

LEDs 

P8

Data

COM1 COM2COM1

DI ,Wake up  
Termination Connector

Power,AI Termination 
Connector

DO Termination 
Connector

 Super32-L201 Down Board   

Fig.B- 9 

 

P1 terminal (including power supply, AI output terminal) has been shown in the figure. 

1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig.B- 10 
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P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig.B- 11 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

 

Fig.B- 12 

 

P4 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig.B- 13 

 

Note：P3 and P4 are both COM1 serial ports, they can not be used in RS485 and 

RS232 at the same time. Only one of them can be selected.  

P5 terminal (including RS232 communication terminal) has been shown in the figure, 

it belongs to COM2. 
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B.3 Super32-L202 

B.3.1 Field Wiring Connectors 

The distribution of Super32-L202 terminal groups shown as follows: 

1) Down Board 

P6

P4P2 P5P1 P3

WAKEUP

-+

Ethernet

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4DI3DI2DI1DI0

LEDs 

P8

Data

COM1 COM2COM1

DI ,Wake up  
Termination Connector

Power,AI Termination 
Connector

DO Termination 
Connector

 Super32-L202 Down Board   

Fig.B- 17 

 

P1 terminal (including power supply, AI output terminal) has been shown in the figure. 

1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig.B- 18 
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P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig.B- 19 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

 

Fig.B- 20 

 

P4 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig.B- 21 

 

Note：P3 and P4 are both COM1 serial ports, they can not be used in RS485 and 

RS232 at the same time. Only one of them can be selected.  

P5 terminal (including RS232 communication terminal) has been shown in the figure, 

it belongs to COM2. 
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B.4 Super32-L203 

B.4.1 Field Wiring Connectors 

The distribution of Super32-L203 terminal groups shown as follows: 

1) Down Board 

P6

P4P2 P5P1 P3

WAKEUP

-+

Ethernet

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4DI3DI2DI1DI0

LEDs 

P8

Data

COM1 COM2COM1

DI ,Wake up  
Termination Connector

Power,AI Termination 
Connector

DO Termination 
Connector

 Super32-L203 Down Board   

Fig.B- 27 

 

P1 terminal (including power supply, AI output terminal) has been shown in the figure. 

1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig.B- 28 
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P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig.B- 29 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

 

Fig.B- 30 

 

P4 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig.B- 31 

 

Note：P3 and P4 are both COM1 serial ports, they can not be used in RS485 and 

RS232 at the same time. Only one of them can be selected.  

P5 terminal (including RS232 communication terminal) has been shown in the figure, 

it belongs to COM2. 
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Appe                                      ndix B Field Wiring of all Super32 Types   

B.5 Super32-L205 

B.5.5 Field Wiring Connectors 

The distribution of Super32-L205 terminal groups shown as follows: 

1) Down Board 

P6

P4P2 P5P1 P3

WAKEUP

-+

Ethernet

RS485 RS232RS232

VDO-DO+

-+
VDO0 DO3DO2DO1V-AI5AI4A3AI2AI1AI0V-V+

DICOM DI7D6DI5DI4DI3DI2DI1DI0

LEDs 

P8

Data

COM1 COM2COM1

DI ,Wake up  
Termination Connector

Power,AI Termination 
Connector

DO Termination 
Connector

 Super32-L205 Down Board   

Fig.B- 37 

 

P1 terminal (including power supply, AI output terminal) has been shown in the figure. 

1 2 3 4 5 6 7 8 9 10

V+ V- AI0 AI2 AI4 V-

P1

AI1 AI3 AI5
 

Fig.B- 38 
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P2 terminal (including DO signal terminal) has been shown in the figure. 

11 12 13 14 15 16

DO1 DO2 DO3 DOV-DOV+DO0

P2

 

Fig.B- 39 

 

P3 terminal (including RS485 communication terminal) has been shown in the figure. 

17 18

_+

P3

Data

 

Fig.B- 40 

 

P4 terminal (including RS232 communication terminal) has been shown in the figure. 

 

Fig.B- 41 

 

Note：P3 and P4 are both COM1 serial ports, they can not be used in RS485 and 

RS232 at the same time. Only one of them can be selected.  

P5 terminal (including RS232 communication terminal) has been shown in the figure, 

it belongs to COM2. 
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                                        Appendix B Field Wiring of all Super32 Types 

P3 terminal (including DO terminal) has been shown in the figure. 

18 19 20 21 22 23

DO1 DO2 DO3 DO5DO4DO0

P3
25 26 27

DO7 DOV- DOV+

24

DO6
 

Fig.B- 50 

 

P4 terminal (including AO terminal) has been shown in the figure. 

28 29 30 31 32 33

AO- AO1 AO- AO-AO2AO0

P4
34 35

AO-AO+
 

Fig.B- 51 

 

P5 terminal (including RS485 communication terminal) has been shown in the figure. 

36 37

D0+D0-

P5

RS485-0

38 39

RS485-1

40 41

RS485-2
D1+D1- D2+D2-  

Fig.B- 52 

 

P6 terminal (including RS232 communication terminal) has been shown in the figure. 

It belongs to COM0. 

 

Fig.B- 53 
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